Knowledgebase
How do I install MetaTrader on my IamFX VPS account?
Posted by - NA - on 11 August 2009 12:45 PM
You don't need to. IamFX MetaTrader will be pre-Installed for you. If your version of Metatrader has become corrupted, please go to www.iamfx.com/mt4download to get the latest version of MT4.
(70 votes)
This article was helpful
This article was not helpful

Help Desk Software by Kayako Fusion